$re = '/[A-Za-z\x{0600}-\x{06FF}\x{1000}-\x{1021}_-][-\w]*/m';
$str = 'Abyssinian 987
Burmese a1a
Dragon Li 2B
987 Cat
cat 987 Toyger
cat A1A Siamese
1
abc-Burmese-a1a';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;