use strict;
my $str = 'Abyssinian 987
Burmese a1a
Dragon Li 2B
987 Cat
cat 987 Toyger
cat A1A Siamese
1
abc-Burmese-a1a';
my $regex = qr/[A-Za-z\x{0600}-\x{06FF}\x{1000}-\x{1021}_-][-\w]*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";