# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[A-Za-z\x{0600}-\x{06FF}\x{1000}-\x{1021}_-][-\w]*//gm;t' <<< "Abyssinian 987
Burmese a1a
Dragon Li 2B
987 Cat
cat 987 Toyger
cat A1A Siamese
1
abc-Burmese-a1a"