import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Za-z\\x{0600}-\\x{06FF}\\x{1000}-\\x{1021}_-][-\\w]*";
final String string = "Abyssinian 987\n"
+ "Burmese a1a\n"
+ "Dragon Li 2B\n"
+ "987 Cat\n"
+ "cat 987 Toyger\n"
+ "cat A1A Siamese\n"
+ "1\n"
+ "abc-Burmese-a1a";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}