const regex = /[A-Za-z\x{0600}-\x{06FF}\x{1000}-\x{1021}_-][-\w]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Za-z\\x{0600}-\\x{06FF}\\x{1000}-\\x{1021}_-][-\\w]*', 'gm')
const str = `Abyssinian 987
Burmese a1a
Dragon Li 2B
987 Cat
cat 987 Toyger
cat A1A Siamese
1
abc-Burmese-a1a`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);