import Foundation
let pattern = ##"""
#begin regex
(?:
#artist
(?:
(.*?)
#end artist
)
#feat
(?:
(?:\s?[(]?\s?
(?:(?:featuring|feat|ft)(?:\.?\/?)(?:\s?)
(?:(.*?)
(?:\s?[)]?\s?
#end feat
)))))
#feat closed
#title
(?:
(?:\s?[-)]\s?
(?:(.*?)
#end title
)?)?)
#title closed
#remix
(?:
(?:\s?[(]\s?
(?:(.*?)
(?:\s?[)]\s?
#end remix
))))
#remix closed
#post-feat
(?:
(?:.*?
(?:\s?[(]?\s?
(?:(?:featuring|feat|ft)(?:\.?\/?(.*?))
(?:\s?[)]\s?
#end post-feat
)?)?)?)?)$
#post-feat closed
#end regex
)$
#regex closed
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"Bakermat (feat. Kiesza) - Don't Want You Back (Extended Mix) feat kesha"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}