// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)#begin regex
(?:
#artist
(?:
(.*?)
#end artist
)
#feat
(?:
(?:\s?[(]?\s?
(?:(?:featuring|feat|ft)(?:\.?\/?)(?:\s?)
(?:(.*?)
(?:\s?[)]?\s?
#end feat
)))))
#feat closed
#title
(?:
(?:\s?[-)]\s?
(?:(.*?)
#end title
)?)?)
#title closed
#remix
(?:
(?:\s?[(]\s?
(?:(.*?)
(?:\s?[)]\s?
#end remix
))))
#remix closed
#post-feat
(?:
(?:.*?
(?:\s?[(]?\s?
(?:(?:featuring|feat|ft)(?:\.?\/?(.*?))
(?:\s?[)]\s?
#end post-feat
)?)?)?)?)$
#post-feat closed
#end regex
)$
#regex closed").unwrap();
let string = "Bakermat (feat. Kiesza) - Don't Want You Back (Extended Mix) feat kesha";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}