re = /#begin regex
(?:
#artist
(?:
(.*?)
#end artist
)
#feat
(?:
(?:\s?[(]?\s?
(?:(?:featuring|feat|ft)(?:\.?\/?)(?:\s?)
(?:(.*?)
(?:\s?[)]?\s?
#end feat
)))))
#feat closed
#title
(?:
(?:\s?[-)]\s?
(?:(.*?)
#end title
)?)?)
#title closed
#remix
(?:
(?:\s?[(]\s?
(?:(.*?)
(?:\s?[)]\s?
#end remix
))))
#remix closed
#post-feat
(?:
(?:.*?
(?:\s?[(]?\s?
(?:(?:featuring|feat|ft)(?:\.?\/?(.*?))
(?:\s?[)]\s?
#end post-feat
)?)?)?)?)$
#post-feat closed
#end regex
)$
#regex closed/x
str = 'Bakermat (feat. Kiesza) - Don\'t Want You Back (Extended Mix) feat kesha'
# Print the match result
str.match(re) do |match|
puts match.to_s
end