#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)#begin regex" & @CRLF & _
"(?:" & @CRLF & _
"" & @CRLF & _
"#artist" & @CRLF & _
"(?:" & @CRLF & _
"(.*?)" & @CRLF & _
"#end artist" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"#feat" & @CRLF & _
"(?:" & @CRLF & _
"(?:\s?[(]?\s?" & @CRLF & _
"(?:(?:featuring|feat|ft)(?:\.?\/?)(?:\s?)" & @CRLF & _
"(?:(.*?)" & @CRLF & _
"(?:\s?[)]?\s?" & @CRLF & _
"#end feat" & @CRLF & _
")))))" & @CRLF & _
"#feat closed" & @CRLF & _
"" & @CRLF & _
"#title" & @CRLF & _
"(?:" & @CRLF & _
"(?:\s?[-)]\s?" & @CRLF & _
"(?:(.*?)" & @CRLF & _
"#end title" & @CRLF & _
")?)?)" & @CRLF & _
"#title closed" & @CRLF & _
"" & @CRLF & _
"#remix" & @CRLF & _
"(?:" & @CRLF & _
"(?:\s?[(]\s?" & @CRLF & _
"(?:(.*?)" & @CRLF & _
"(?:\s?[)]\s?" & @CRLF & _
"#end remix" & @CRLF & _
"))))" & @CRLF & _
"#remix closed" & @CRLF & _
"" & @CRLF & _
"#post-feat" & @CRLF & _
"(?:" & @CRLF & _
"(?:.*?" & @CRLF & _
"(?:\s?[(]?\s?" & @CRLF & _
"(?:(?:featuring|feat|ft)(?:\.?\/?(.*?))" & @CRLF & _
"(?:\s?[)]\s?" & @CRLF & _
"#end post-feat" & @CRLF & _
")?)?)?)?)$" & @CRLF & _
"#post-feat closed" & @CRLF & _
"" & @CRLF & _
"#end regex" & @CRLF & _
")$" & @CRLF & _
"#regex closed"
Local $sString = "Bakermat (feat. Kiesza) - Don't Want You Back (Extended Mix) feat kesha"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")