const regex = /#begin regex
(?:
#artist
(?:
(.*?)
#end artist
)
#feat
(?:
(?:\s?[(]?\s?
(?:(?:featuring|feat|ft)(?:\.?\/?)(?:\s?)
(?:(.*?)
(?:\s?[)]?\s?
#end feat
)))))
#feat closed
#title
(?:
(?:\s?[-)]\s?
(?:(.*?)
#end title
)?)?)
#title closed
#remix
(?:
(?:\s?[(]\s?
(?:(.*?)
(?:\s?[)]\s?
#end remix
))))
#remix closed
#post-feat
(?:
(?:.*?
(?:\s?[(]?\s?
(?:(?:featuring|feat|ft)(?:\.?\/?(.*?))
(?:\s?[)]\s?
#end post-feat
)?)?)?)?)$
#post-feat closed
#end regex
)$
#regex closed/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#begin regex
(?:
#artist
(?:
(.*?)
#end artist
)
#feat
(?:
(?:\\s?[(]?\\s?
(?:(?:featuring|feat|ft)(?:\\.?\\\/?)(?:\\s?)
(?:(.*?)
(?:\\s?[)]?\\s?
#end feat
)))))
#feat closed
#title
(?:
(?:\\s?[-)]\\s?
(?:(.*?)
#end title
)?)?)
#title closed
#remix
(?:
(?:\\s?[(]\\s?
(?:(.*?)
(?:\\s?[)]\\s?
#end remix
))))
#remix closed
#post-feat
(?:
(?:.*?
(?:\\s?[(]?\\s?
(?:(?:featuring|feat|ft)(?:\\.?\\\/?(.*?))
(?:\\s?[)]\\s?
#end post-feat
)?)?)?)?)$
#post-feat closed
#end regex
)$
#regex closed', '')
const str = `Bakermat (feat. Kiesza) - Don't Want You Back (Extended Mix) feat kesha`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}