$re = '/\-?[0-9]*\.?[0-9][0-9]*(E\-?[0-9]+)?/m';
$str = '0.12345
-0.12345
123.45678
.12345
-0.12345E12
123.45678E-123
0
12345
-23456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);