import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\-?[0-9]*\\.?[0-9][0-9]*(E\\-?[0-9]+)?";
final String string = "0.12345\n"
+ "-0.12345\n"
+ "123.45678\n"
+ ".12345\n"
+ "-0.12345E12\n"
+ "123.45678E-123\n"
+ "0\n"
+ "12345\n"
+ "-23456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}