#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\-?[0-9]*\.?[0-9][0-9]*(E\-?[0-9]+)?"
Local $sString = "0.12345" & @CRLF & _
"-0.12345" & @CRLF & _
"123.45678" & @CRLF & _
".12345" & @CRLF & _
"-0.12345E12" & @CRLF & _
"123.45678E-123" & @CRLF & _
"0" & @CRLF & _
"12345" & @CRLF & _
"-23456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")