package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\-?[0-9]*\.?[0-9][0-9]*(E\-?[0-9]+)?`)
var str = `0.12345
-0.12345
123.45678
.12345
-0.12345E12
123.45678E-123
0
12345
-23456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}