using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\-?[0-9]*\.?[0-9][0-9]*(E\-?[0-9]+)?";
string input = @"0.12345
-0.12345
123.45678
.12345
-0.12345E12
123.45678E-123
0
12345
-23456";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}