import Foundation
let pattern = #"^(?'Username'[-\w\d\.]+?)(?:\s+at\s+|\s*@\s*|\s*(?:[\[\]@]){3}\s*)(?'Domain'[-\w\d\.]*?)\s*(?:dot|\.|(?:[\[\]dot\.]){3,5})\s*(?'TLD'\w+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
some.email at gmail dot com
asdf-FDSA at ghjkl . net
thomas at yahoo .de
josh@awesomecompanyname dot com
mona.lisa [@] domain [dot] com
stephen.spielberg [@] domain [.] com
He is not at his best. Lorem Ipsum.
Hit "Perform a substitution" to see some magic happen.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1@\2.\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)