# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?'Username'[-\w\d\.]+?)(?:\s+at\s+|\s*@\s*|\s*(?:[\[\]@]){3}\s*)(?'Domain'[-\w\d\.]*?)\s*(?:dot|\.|(?:[\[\]dot\.]){3,5})\s*(?'TLD'\w+)$"
test_str = ("some.email at gmail dot com\n\n"
"asdf-FDSA at ghjkl . net\n\n"
"thomas at yahoo .de\n\n"
"josh@awesomecompanyname dot com\n\n"
"mona.lisa [@] domain [dot] com\n\n"
"stephen.spielberg [@] domain [.] com\n\n"
"He is not at his best. Lorem Ipsum.\n\n\n\n"
"Hit \"Perform a substitution\" to see some magic happen.")
subst = "\\1@\\2.\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.