$re = '/^(?\'Username\'[-\w\d\.]+?)(?:\s+at\s+|\s*@\s*|\s*(?:[\[\]@]){3}\s*)(?\'Domain\'[-\w\d\.]*?)\s*(?:dot|\.|(?:[\[\]dot\.]){3,5})\s*(?\'TLD\'\w+)$/m';
$str = 'some.email at gmail dot com
asdf-FDSA at ghjkl . net
thomas at yahoo .de
josh@awesomecompanyname dot com
mona.lisa [@] domain [dot] com
stephen.spielberg [@] domain [.] com
He is not at his best. Lorem Ipsum.
Hit "Perform a substitution" to see some magic happen.';
$subst = "\1@\2.\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;