import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?'Username'[-\\w\\d\\.]+?)(?:\\s+at\\s+|\\s*@\\s*|\\s*(?:[\\[\\]@]){3}\\s*)(?'Domain'[-\\w\\d\\.]*?)\\s*(?:dot|\\.|(?:[\\[\\]dot\\.]){3,5})\\s*(?'TLD'\\w+)$";
final String string = "some.email at gmail dot com\n\n"
+ "asdf-FDSA at ghjkl . net\n\n"
+ "thomas at yahoo .de\n\n"
+ "josh@awesomecompanyname dot com\n\n"
+ "mona.lisa [@] domain [dot] com\n\n"
+ "stephen.spielberg [@] domain [.] com\n\n"
+ "He is not at his best. Lorem Ipsum.\n\n\n\n"
+ "Hit \"Perform a substitution\" to see some magic happen.";
final String subst = "\\1@\\2.\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}