# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?'Username'[-\w\d\.]+?)(?:\s+at\s+|\s*@\s*|\s*(?:[\[\]@]){3}\s*)(?'Domain'[-\w\d\.]*?)\s*(?:dot|\.|(?:[\[\]dot\.]){3,5})\s*(?'TLD'\w+)$/\1@\2.\3/gm;t' <<< "some.email at gmail dot com
asdf-FDSA at ghjkl . net
thomas at yahoo .de
josh@awesomecompanyname dot com
mona.lisa [@] domain [dot] com
stephen.spielberg [@] domain [.] com
He is not at his best. Lorem Ipsum.
Hit \"Perform a substitution\" to see some magic happen."