# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=([aui]))[wy](?=\1)|(?<=i)[wy](?=u)"
test_str = ("asdawasda\n"
"asdayasda\n"
"asdiwisda\n"
"asdiyisda\n"
"asduwusda\n"
"asduyusda\n\n"
"asdawisda\n"
"asdawusda\n\n"
"asdayisda\n"
"asdayusda\n\n"
"asdiwasda\n"
"asdiwusda\n\n"
"asdiyasda\n"
"asdiyusda\n\n"
"asduwasda\n"
"asduwisda\n\n"
"asduyasda\n"
"asduyisda\n\n"
"ramiyun\n"
"da9iwun")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.