use strict;
my $str = 'asdawasda
asdayasda
asdiwisda
asdiyisda
asduwusda
asduyusda
asdawisda
asdawusda
asdayisda
asdayusda
asdiwasda
asdiwusda
asdiyasda
asdiyusda
asduwasda
asduwisda
asduyasda
asduyisda
ramiyun
da9iwun';
my $regex = qr/(?<=([aui]))[wy](?=\1)|(?<=i)[wy](?=u)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";