const regex = new RegExp('(?<=([aui]))[wy](?=\\1)|(?<=i)[wy](?=u)', 'g')
const str = `asdawasda
asdayasda
asdiwisda
asdiyisda
asduwusda
asduyusda
asdawisda
asdawusda
asdayisda
asdayusda
asdiwasda
asdiwusda
asdiyasda
asdiyusda
asduwasda
asduwisda
asduyasda
asduyisda
ramiyun
da9iwun`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);