import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=([aui]))[wy](?=\\1)|(?<=i)[wy](?=u)";
final String string = "asdawasda\n"
+ "asdayasda\n"
+ "asdiwisda\n"
+ "asdiyisda\n"
+ "asduwusda\n"
+ "asduyusda\n\n"
+ "asdawisda\n"
+ "asdawusda\n\n"
+ "asdayisda\n"
+ "asdayusda\n\n"
+ "asdiwasda\n"
+ "asdiwusda\n\n"
+ "asdiyasda\n"
+ "asdiyusda\n\n"
+ "asduwasda\n"
+ "asduwisda\n\n"
+ "asduyasda\n"
+ "asduyisda\n\n"
+ "ramiyun\n"
+ "da9iwun";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}