# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=([aui]))[wy](?=\1)|(?<=i)[wy](?=u)//g;t' <<< "asdawasda
asdayasda
asdiwisda
asdiyisda
asduwusda
asduyusda
asdawisda
asdawusda
asdayisda
asdayusda
asdiwasda
asdiwusda
asdiyasda
asdiyusda
asduwasda
asduwisda
asduyasda
asduyisda
ramiyun
da9iwun"