// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)Vertel( me)? een (grap|mop)|(zeg|vertel)( me)? iets (grappigs|leuks)|tap een mop|maak een grap").unwrap();
let string = "tap een mop
maak een grap
vertel een grap
vertel me een grap
vertel een mop
vertel me een mop
zeg iets grappigs
zeg me iets grappigs
vertel iets grappigs
vertel me iets grappigs
zeg iets leuks
zeg me iets leuks
vertel iets leuks
vertel me iets leuks
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}