#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)Vertel( me)? een (grap|mop)|(zeg|vertel)( me)? iets (grappigs|leuks)|tap een mop|maak een grap"
Local $sString = "tap een mop" & @CRLF & _
"maak een grap" & @CRLF & _
"vertel een grap" & @CRLF & _
"vertel me een grap" & @CRLF & _
"vertel een mop" & @CRLF & _
"vertel me een mop" & @CRLF & _
"zeg iets grappigs" & @CRLF & _
"zeg me iets grappigs" & @CRLF & _
"vertel iets grappigs" & @CRLF & _
"vertel me iets grappigs" & @CRLF & _
"zeg iets leuks" & @CRLF & _
"zeg me iets leuks" & @CRLF & _
"vertel iets leuks" & @CRLF & _
"vertel me iets leuks" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")