using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Vertel( me)? een (grap|mop)|(zeg|vertel)( me)? iets (grappigs|leuks)|tap een mop|maak een grap";
string input = @"tap een mop
maak een grap
vertel een grap
vertel me een grap
vertel een mop
vertel me een mop
zeg iets grappigs
zeg me iets grappigs
vertel iets grappigs
vertel me iets grappigs
zeg iets leuks
zeg me iets leuks
vertel iets leuks
vertel me iets leuks
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}