const regex = /Vertel( me)? een (grap|mop)|(zeg|vertel)( me)? iets (grappigs|leuks)|tap een mop|maak een grap/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Vertel( me)? een (grap|mop)|(zeg|vertel)( me)? iets (grappigs|leuks)|tap een mop|maak een grap', 'ig')
const str = `tap een mop
maak een grap
vertel een grap
vertel me een grap
vertel een mop
vertel me een mop
zeg iets grappigs
zeg me iets grappigs
vertel iets grappigs
vertel me iets grappigs
zeg iets leuks
zeg me iets leuks
vertel iets leuks
vertel me iets leuks
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}