$re = '/Vertel( me)? een (grap|mop)|(zeg|vertel)( me)? iets (grappigs|leuks)|tap een mop|maak een grap/i';
$str = 'tap een mop
maak een grap
vertel een grap
vertel me een grap
vertel een mop
vertel me een mop
zeg iets grappigs
zeg me iets grappigs
vertel iets grappigs
vertel me iets grappigs
zeg iets leuks
zeg me iets leuks
vertel iets leuks
vertel me iets leuks
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);