// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?) +(.*?) +(.*?) +\[(.*?)\] +\[(.*?)\] +(.+)$").unwrap();
let string = "2022-11-10 16:22:30,847 WARN [ThreadPoolAsyncTaskExecutor::Thread 34] [addons.analytics.scheduler.DataRetentionScheduleManagerImpl] afterPropertiesSet Initializing Data Retention Schedule with frequency: 60000 milliseconds, batch size: 10000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}