$re = '`^(.*?) +(.*?) +(.*?) +\[(.*?)\] +\[(.*?)\] +(.+)$`m';
$str = '2022-11-10 16:22:30,847 WARN [ThreadPoolAsyncTaskExecutor::Thread 34] [addons.analytics.scheduler.DataRetentionScheduleManagerImpl] afterPropertiesSet Initializing Data Retention Schedule with frequency: 60000 milliseconds, batch size: 10000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);