const regex = new RegExp('^(.*?) +(.*?) +(.*?) +\\[(.*?)\\] +\\[(.*?)\\] +(.+)$', 'gm')
const str = `2022-11-10 16:22:30,847 WARN [ThreadPoolAsyncTaskExecutor::Thread 34] [addons.analytics.scheduler.DataRetentionScheduleManagerImpl] afterPropertiesSet Initializing Data Retention Schedule with frequency: 60000 milliseconds, batch size: 10000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}