package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?) +(.*?) +(.*?) +\[(.*?)\] +\[(.*?)\] +(.+)$`)
var str = `2022-11-10 16:22:30,847 WARN [ThreadPoolAsyncTaskExecutor::Thread 34] [addons.analytics.scheduler.DataRetentionScheduleManagerImpl] afterPropertiesSet Initializing Data Retention Schedule with frequency: 60000 milliseconds, batch size: 10000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}