re = /^(.*?) +(.*?) +(.*?) +\[(.*?)\] +\[(.*?)\] +(.+)$/m
str = '2022-11-10 16:22:30,847 WARN [ThreadPoolAsyncTaskExecutor::Thread 34] [addons.analytics.scheduler.DataRetentionScheduleManagerImpl] afterPropertiesSet Initializing Data Retention Schedule with frequency: 60000 milliseconds, batch size: 10000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end