$re = '/<(.+?)(?: (.+?)=(.+?))*?>.*?<\/\1>/m';
$str = '<w c5="NP0" hw="michael" pos="SUBST">Michael </w>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;