# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(.+?)(?: (.+?)=(.+?))*?>.*?<\\/\1>//mg;t' <<< "<w c5=\"NP0\" hw=\"michael\" pos=\"SUBST\">Michael </w>"