use strict;
my $str = '<w c5="NP0" hw="michael" pos="SUBST">Michael </w>';
my $regex = qr/<(.+?)(?: (.+?)=(.+?))*?>.*?<\/\1>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";