const regex = /<(.+?)(?: (.+?)=(.+?))*?>.*?<\/\1>/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(.+?)(?: (.+?)=(.+?))*?>.*?<\\\/\\1>', 'mg')
const str = `<w c5="NP0" hw="michael" pos="SUBST">Michael </w>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);