re = /^(?<n>(?:@(?<org>[a-z0-9-~][a-z0-9-._~]*)\/)?(?<pkg>[a-z0-9-~][a-z0-9-._~]*))(?:@(?<v>[-a-z0-9><=_.^~*| ]+))?(?<p>\/[^\r\n]*)?$/m
str = 'react-icons@4.4.0/
@heroicons/react@latest/package.json
react
react/hello
react@1
react/
reaction@1.1.1/index.js
react@*
react@>1.2|| <= 1.*
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end