#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<n>(?:@(?<org>[a-z0-9-~][a-z0-9-._~]*)\/)?(?<pkg>[a-z0-9-~][a-z0-9-._~]*))(?:@(?<v>[-a-z0-9><=_.^~*| ]+))?(?<p>\/[^\r\n]*)?$"
Local $sString = "react-icons@4.4.0/" & @CRLF & _
"@heroicons/react@latest/package.json" & @CRLF & _
"react" & @CRLF & _
"react/hello" & @CRLF & _
"react@1" & @CRLF & _
"react/" & @CRLF & _
"reaction@1.1.1/index.js" & @CRLF & _
"react@*" & @CRLF & _
"react@>1.2|| <= 1.*" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")