package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<n>(?:@(?<org>[a-z0-9-~][a-z0-9-._~]*)\/)?(?<pkg>[a-z0-9-~][a-z0-9-._~]*))(?:@(?<v>[-a-z0-9><=_.^~*| ]+))?(?<p>\/[^\r\n]*)?$`)
var str = `react-icons@4.4.0/
@heroicons/react@latest/package.json
react
react/hello
react@1
react/
reaction@1.1.1/index.js
react@*
react@>1.2|| <= 1.*
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}