const regex = /^(?<n>(?:@(?<org>[a-z0-9-~][a-z0-9-._~]*)\/)?(?<pkg>[a-z0-9-~][a-z0-9-._~]*))(?:@(?<v>[-a-z0-9><=_.^~*| ]+))?(?<p>\/[^\r\n]*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<n>(?:@(?<org>[a-z0-9-~][a-z0-9-._~]*)\\\/)?(?<pkg>[a-z0-9-~][a-z0-9-._~]*))(?:@(?<v>[-a-z0-9><=_.^~*| ]+))?(?<p>\\\/[^\\r\\n]*)?$', 'gm')
const str = `react-icons@4.4.0/
@heroicons/react@latest/package.json
react
react/hello
react@1
react/
reaction@1.1.1/index.js
react@*
react@>1.2|| <= 1.*
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}