$re = '/^(?<n>(?:@(?<org>[a-z0-9-~][a-z0-9-._~]*)\/)?(?<pkg>[a-z0-9-~][a-z0-9-._~]*))(?:@(?<v>[-a-z0-9><=_.^~*| ]+))?(?<p>\/[^\r\n]*)?$/m';
$str = 'react-icons@4.4.0/
@heroicons/react@latest/package.json
react
react/hello
react@1
react/
reaction@1.1.1/index.js
react@*
react@>1.2|| <= 1.*
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);