$re = '/(?:CONTA|C/C)?(?:\sCORRENTE)?\s?(?:PJ)?\s?:?\s?\d+[-./]?\d+/m';
$str = 'CONTA CORRENTE: 18465416565
CONTA: 878976874
CONTA CORRENTE PJ: 4444546484
C/C: 88446454564-7897988
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);