using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:CONTA|C/C)?(?:\sCORRENTE)?\s?(?:PJ)?\s?:?\s?\d+[-./]?\d+";
string input = @"CONTA CORRENTE: 18465416565
CONTA: 878976874
CONTA CORRENTE PJ: 4444546484
C/C: 88446454564-7897988
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}