const regex = new RegExp('(?:CONTA|C/C)?(?:\\sCORRENTE)?\\s?(?:PJ)?\\s?:?\\s?\\d+[-./]?\\d+', 'gm')
const str = `CONTA CORRENTE: 18465416565
CONTA: 878976874
CONTA CORRENTE PJ: 4444546484
C/C: 88446454564-7897988
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}