#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:CONTA|C/C)?(?:\sCORRENTE)?\s?(?:PJ)?\s?:?\s?\d+[-./]?\d+"
Local $sString = "CONTA CORRENTE: 18465416565" & @CRLF & _
"CONTA: 878976874" & @CRLF & _
"CONTA CORRENTE PJ: 4444546484" & @CRLF & _
"C/C: 88446454564-7897988" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")