import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:CONTA|C/C)?(?:\\sCORRENTE)?\\s?(?:PJ)?\\s?:?\\s?\\d+[-./]?\\d+";
final String string = "CONTA CORRENTE: 18465416565\n"
+ "CONTA: 878976874\n"
+ "CONTA CORRENTE PJ: 4444546484\n"
+ "C/C: 88446454564-7897988\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}