re = /(?i)\..*? (?P<error>\w+)(?= )/
str = '2014-09-12 03:25:16.549: org.eclipse.jetty.server.AsyncHttpConnection WARN - Closing EndPoint making no progress:'
# Print the match result
str.match(re) do |match|
puts match.to_s
end